COM 4 Port already in use, how do I fix this message?

Guys, (and girls), I’m having 2 issues that I hope someone will be able to help me out.

I’m trying to connect with the MBot but I get an error message that says “Connection error. “COM4” port already in use. Try quitting any programs that might be using it” I can’t figure out how the fix this problem. I’ve tried changing the USB port, didn’t work. I tried to change the COM port in the device manager but that didn’t work. I tired to rescan the serial ports, didn’t work. Any ideas what to try next?

Also, I have the SD card reader that will not read the SD card. The reader says the SD card is empty but when I take a look at it in the computer, there is a STL file on there with the G-Code. The reader gave a message about reformatting to FAT 16 although the SD card I was sent with the printer is an 8GB Scandisk SD card. Any ideas on this issue?

Any help will be greatly appreciated.


1.To connect your printer to the computer ,you need 1)maker sure you have intalled all the drivers
2) choose your machine type 3)then rescan the serial port .4)choose the serial port 5)and then connect it .

2.our printer can only read “.x3g” file ,you need to transfer the gcode to .x3g in our software ,actually there is a “send to SD card” button ,just choose it .
if the SD card is not the right format ,use your computer format it in “FAT 32”

I had the same problem with my main computer. I found that that I got it when I started ReplicatorG after I had turned on the printer. but if I start replicatorG before I turn it on, it seems to work fine.

Thanks for the advice. 1) turn on the computer, 2) open Replicator G, 3) plug in the USB cable, 4) then turn on the machine. Scan for available COMM ports and it works. Go figure. It helps to do a little dance as well. :smile: