Customer Support With DIY Plywood

My wife let me open a Christmas present early. I was excited to see she got a 3d printer; my first printer.

Step #1 Install X axis end stop…hmmmm…where’s the end stop??? Nope…not here.

So I moved forward…

Step #7 Install the two linear bearings on the build platform. Found the ziploc baggie with the parts…BUT…there were about 5 small ball bearings loose in the baggie along with the linear bearings. That had me concerned.

I opened a support ticket 12/24/17 regarding this issue of missing and damaged parts. The website said they would get back to me in 2-3 days. No response from tech support, so I emailed them again 12/29/17 and opened a second support ticket 12/31/17.

No response from tech support.

I have a 97% completed printer that’s been sitting on my desk for 11 days, and I haven’t been able to turn it on to use it.

Forum…what’s been your experience with tech support in relation to replacement parts and response to issues?

Mbot guys…I’m not saying bad things, but I’m very disappointed that I have an incomplete product and feel like there’s zero support with your product.

Well, at least I got a response to my inquiry, my PSU was DOA. I got my kit from Amazon, and had to resolve it through Amazon support. (I got a different PSU shipped out right away,) One of my linear bearings in the X carriage also is NG, but I just used a spare I happen to have.

My limit switch wasn’t where I expected it, but was in the package. Those bearings do lose some if they get shaken with no rod inside. it will probably still work fine, and you can put the loose bearings back in if you have them. The X and Y limit switches are standard parts and cheap, as are the bearings. At least you should be able to get replacement parts quickly if you don’t get a reply soon.

For the record, I am also a little disappointed with the customer service. I wonder if it’s better with the more expensive products. The DIY kit is of course the least expensive in the store. I will say that this is not my first printer, and even with the issues I’ve had , it’s better than the others I’ve had.


I ended up getting some end stops thru ebay. So that part is resolved. I installed the end stop, but the darn thing doesn’t home properly. Probably something messed up in the config h files. If yours is working fine, can you send me a copy of your config h file so I can compare? I’d appreciate it!!


I wish that I could, but I didn’t get source for the firmware, it was just loaded on the board, and I can’t touch it. I believe that the X_HOME_DIR and Y_HOME_DIR should both be 1 and Z as -1. I think my board presents as an AT Mega 2560/RAMPS combo, so I should be able to reflash Marlin, but I want to be able to revert to baseline. at present, mine annoyingly hangs waiting to reach temperature, and needs manual intervention to get past that point.

1 Like

Sorry to hear your order was bunk. Plus no response from the team.

I got a used one off of Craigslist and it worked perfect right out of the box. For me, my trouble is filament holding to the build surface too much. Got build tak and it ripped trying to separate model from plate. Glue stick is the way to go.

So what do you need help with? Mine is stand alone wood mbot. But I will try to help.
Mbot has firmware stuff. The guy who sold me the printer said the latest firmware messes it up. So my suggestion is to download the previous version and try that. Also motors can be reversed connected. So you want to reverse the wiring if it homes wrong.

Good luck! You will get it working and feel good about it. :slight_smile:


I’ve had a heck of a time trying to find the right firmware for this thing!! I thought I found the right one and now my LCD is showing two rows of blocks. I hope I didn’t brick the motherboard.

Can you, or anyone else send me a copy of the earliest and stable config h files? Or point me to where the one that’s working for you can be found?

I would also really like to update my firmware, but I’m quite concerned about the choices available.

In the support section, there are files for the “DIY Cube” which seems promising, however, there seems to have been at least some major revisions in the DIY kit, and I will not go ahead until I am sure that I’d be working with the correct kit.

The mechanics of the machine look similar enough, but the electronics are entirely different. I would not expect that the firmware for one board works at all on the other.

This is my mainboard…

This company must have closed up shop…aside from keeping this forum open. I have a piece of plywood/metal/plastic that is useless! Not a single reply via email. I’ve even sent letters via USPS to their “US Office” as well as to their office in China. No response.

I ordered an endstop on ebay to finish the build, since one was missing in the kit.

Sadly, I’m still trying to figure out how to revive the motherboard. I’m new to the 3d printing (especially with Arduino programming the Configuration.h files)…and very frustrated.

My wife let me buy something that works right out of the box and is coupled with tech support, since she saw the frustration I was having with the MBot DIY. I bought a QIDI Tech 1 printer and have been extremely happy with it. I’ve made some great prints with this printer.

I’d still like to do something with the MBot P.O.S plastic/metal/wood parts.

Anyone have a config.h file??? Any idea how to revive the MKS Gen L 1.0 Motherboard?? All I have are two rows of blocks on the LCD screen.


I’m with you on the frustration level.

There are places that you can buy a MKS GEN_L board, and there are many other solutions that will work. I’ve been considering buying a second board so that I can experiment with firmware and know that I have a working replacement. In general, the connections to the hardware are fairly generic, and I’ve also been considering buying a more capable mainboard, like one of those based on a 16 bit processor, though that would probably require changing the screen interface.

I am working on getting a good Configuration.h file, and when I’m done, I’ll post it up, so that other people don’t need to go through this crap. I’m a programmer by trade, so I figure that I’ve got a fighting shot at it. I just want to add heated build platform support, which the hardware should handle.

I will say that most likely what you’re missing with your Configuration.h file is the line for the display type. The display that my kit shipped with is the RepRap Discount Controller. Sometimes listed as a 2004 (20 columns by 04 lines display) This might help you. Chances are that you have don no damage to the controller by uploading your firmware, but it needs to be set right in order to utilize the display. I believe from the documentation that you configure the firmware as an Arduino 2560 + RAMPS 1.3/1.4 board. That with the RepRap Discount Controller should get you something that at least gives you the basics.

You will have to set the bed dimensions (250mm by 220mm) and configure it to use the X_MAX, Y_MAX and Z_MIN endstops. IIRC, you want to use use inverted logic (positive trigger) for the endstops, but I could be wrong there. I don’t know about motor control.

I have an actual spare Arduino/RAMPS combination, and if I don’t buy a spare MKS GEN_L board, I’ll use that to develop the firmware. I haven’t done so yet because a 24V power supply for this is something of a bother.

Supra Guy,

Thanks for the “breadcrumb trail” to follow in order to correct my issues.

You keep me posted on your advances, and I’ll do the same!!

I’ll give the tweaks a try. The configuration.h files can be a bit daunting. The odd part is DL’ing a fresh marlin file and verifying it gives errors. I’m contemplating trying a sailfish FW install (you can’t fall further than the floor).

A heated bed is nice. I’ve had some failed prints on my QIDI Tech 1 without applying a glue stick and heating the bed to 40deg C for PLA and 100deg C for ABS. The dual nozzles on this printer is a nice upgrade to the single nozzle on the Mbot DIY. I made an awesome Chromatic Vase

I bought some PVA so I can print a Voronoi Heart without visible supports within the interior. My first print, I was unable to remove the supports.

I’m still going to keep on trudging on in trying to get the MBot DIY going. I appreciate your advice and Guidance.

Update 3/1/18…My letter to Magicfirm, LLC’s US office was returned. No forwarding address given.

How 'bout them apples?

I wonder if going with the setup that the prusa has. Like the arduino and shield. then config it from there. Its just motors and measurement.

So from what I understand. The latests firmware doesnt work well. You have to use the one before.

The board that this ships with is an integrated board that combines a Mega 2560 and RAMPS 1.4, with the difference that it’s alreay 24V capable, which the RAMPS board isn’t (Unless modified)

If I were going to change the mainboard, I would probably go with something that has greater capability, rather than the same or lesser. Fortunately, the motors, extruder and fans are all pretty standard stuff, with everything dialled in for 24V already, so there are a lot of frankly better control options out there.

Well, my new control board has arrived, so it’s time to start reverse engineering the firmware, and see if I can get Marlin 1.1.8 as a stable release running on it.

I believe that this isn’t too tricky a printer to work with, it’s a pretty standard Cartesian configuration, and I found the steps/mm on the existing firmware, so I can just copy that across, since it seems to work well enough. The bed leveling is new to me. It wasn’t a thing last time I configured a printer. Once I have a good configuration file, I’ll be glad to wave good bye to the issues that this thing has been plagued with. It’ll be strange to be able to just tell it to print something without the babysitting, but I’ll like it.


What board did you end up buying?

I removed and passed the original board to a friend of mine to tinker with, see if it will come back to life. Before that, I borrowed an Arduino Uno and followed some online instructions to re-install a bootloader onto the MKS Gen L V 1.0 board. There was slight progress of getting not only a static red LED on the board, but I also got a blue blinking LED. I was still unable to load any firmware, and not completely sure that I did in fact load a bootloader onto the board. But it felt like progress (in the right direction).

I still have a Chinese wooden box with plastic and metal parts (Since opening it up Dec. 25, 2017). It’s sitting in my garage, up on a shelf.

I’m having great progress/results with my QIDI Tech 1 printer!!! I just recently removed the stock “Build Tac” (sp?) and purchased a couple of pieces of glass that fits the bed. I printed some clips (that needed some minor modification) off of Thingiverse and have been rocking and rolling with the printer.

I’m looking forward to hearing about your progress with loading firmware on your new board. It’s a great feeling to watch a configured printer lay down it’s first layer and walking away from it and letting it do it’s thing without babysitting it.

Well, I got a couple of options.

I bought a Duet Wifi board, which is heavy overkill, but has some very nice features. I actually intend to use this for my own design printer, because it’s way more than this design needs in any way, shape or form, but the features look pretty nice so far. I’ve only connected it experimentally to the other one (Just has the chassis, there’s no hot end or extruder, nor is there a print surface.

I also bought an MKS GEN v1.4. It’s a little different from the GEN-L, but ultimately very similar. It runs the same main processor, and emulates the same original design (Arduino Mega 2560 + RAMPS 1.4) with the same connectors. I figured that this would make for the most similar starting point, but with a brand new board, I don’t have to worry about messing up the firmware that I have which works, though of course not without issues.

I do start to think that all of these things have their issues, you just choose the set of issues that you can work with, and run with it.

I’m going to try to get the latest stable release of Marlin running on the board. I think that the version that is on the GEN-L is a 1.1.0 unstable release candidate. I figured that I’d start from 1.1.8, which is supposed to be more stable. I have the settings that I know all written down, so where the endstop switches are, bed dimensions, steps/mm. I’m not entirely certain of the settings for bed leveling, and homing the Z axis, but I’ll cross that bridge when I get there.

I will say that the Duet Wifi board is really nice to work with. I intended to use it for my home designed printer, but I’m giving serious consideration to using one for the MBot. The disadvantage is that you lose the LCD controller, but since you can upload gcode to the SD card via wifi, it eliminates the sneakernet step of putting the SD card in the computer, then putting it in the printer. Or of course you can connect to the USB, but that isn’t really convenient for me.

Well, I’ve taken my first steps.

I’ve gone through the easy stuff, and compiled and uploaded Marlin 1.1.8 with the configuration information that I know. Bed size, steps/mm, and I think that I have the 3 point bed leveling configured, though that… remains to be seen. I’m also not sure how the offset configuration and Z homing will work until I physically change out the control board. I think that I have the endstop logic configured correctly.

I have it configured for the RepRap Discount controller, so that should work the same. It looks like the GEN v1.4 is a little longer a board than the GEN-L, but I think that 2 of the mount points may be the same relative tot he USB port, so I might be able to just drill 2 new mount holes and still use the USB opening in the side of the printer. (Good news for when it’s time to try re-compiling the firmware!)

I’ve verified that I can connect to the new board via PronterFace, so the firmware is definitely running, and can accept commands.

When I ordered the board, I neglected to order new stepper drivers. I do have a set on my old RAMPS board, which I’ll just have to transfer over, and re-set the driver current.

I’ve been thinking of what to do with the heated bed.

I definitely want one, but I don’t think that the included power supply is adequate to supply for it.

I have 3 actual heated beds to choose from. One is a 200mmX200mm Mk3 bed that can be configured for 12V or 24V input (Currently configured for 12V, as it was for my I3 clone build, but I could change that in a few minutes with a soldering iron.) Mostly, I don’t want to use this because it would restrict my available build area. I have 2 more that are 220mm by 275mm. One is 12V and the other is 24V. I think that what I’m going to do is use the 12V one. In order to do this, I planned to use an external MOSFET and then re-use the 12V power supply from my I3. I think that this will require the bed heater to be configured in bang bang mode, which is a little bit sub-optimal, but allows me to save the additional 24V supply and 24V heated bed for my other printer build, which is what I plan to use the Duet Wifi controller board with. I think that this allows me the most effective use of the resources that I have available. It may mean that the configuration that I upload here when I’m done will need some changes for other people, but then other people may not want the heated bed, they may just want to be able to upgrade to a newer firmware with the same physical features. After all, the printer itself seems to be reasonably good.

Well, today I’m going to give it a shot.

I’m reasonably confident that most of this configuration is correct, but it is as yet untested. There may be some things like motor directions which need to be changed, but I think that the bed leveling is correctly configured, and the default steps/mm should match. The Z offset isn’t configured, but that can be configured from the controller.

Speaking of which, I noticed that there are sensitivity settings for the encoder. I’ve always found it difficult to make adjustments to settings on the encoder in increments smaller than jumps of 4. At the very least, I plan on making changes to those sensitivity settings so that they make sense. I put in something as “best guess” for adjustments, but I will be fine tuning this. Therefore this configuration file should be treated as “alpha” at best, and not used for a printer that you expect to work.

PROGRESS!!! That’s awesome! More than I could say about my Mbot printer.

I’m definitely looking forward to hearing how you get the bugs worked out.

I’m looking at pulling the pin on buying an MKS 1.4 board myself. I’ve found a few occasions where two working printers would speed up things.

Oh yes, there is progress.

the MKS GEN 1.4 is a littke longer, but 2 mounting holes and the USB port line up perfectly. it uses the same LCD and SD card , and I think that I’ve got the main things sorted.

I don’t have the option to save settings configured, so Z offset has to be set after power cycling the printer, and any other non-default option.

3 point homing for bed leveling works great, bed geometry looks good . My biggest issue now is my power cable for the heated bed needs to be soldered up, and then i can run test prints before I make everything all tidy. I managed to break my bed mount too, with a bad Z homing configuration.

All in all, i think this is going to work great. still glad I didn’t wipe the original board tho.

oh, the LED lights and cooling fan needed to be plugged into different places, but I have figured it out.

Heated bed control will be nice!