We received our GRID II Dual extruder at work yesterday. I installed the latest ReplicatorG software and Python 2.7 according to the poorly written instructions that came with the printer. I leveled the build platform without too much problem. When it came time to add the filament I was able to load the right filament roll, but it seems the machine doesn’t recognize that there is a second extruder on it and the display on the printer never shows anything about a left extruder. It never heats up and the extruder stepper motor never turns on to accept the 1.75mm filament I am trying to feed into it. I confirmed that the ReplicatorG machine setting shows MBOT Cube Dual. I could not find any other setting that would allow me to enable a second extruder. I’m thinking I may need to reload or update the firmware. Anybody know of any other way to get this thing to recognize the 2nd extruder?

Next item: I was able to run the test print just using the single extruder and the tall twisted box seemed to print fine. But when I went to print a second item from the SD card the build platform shot up and ran into the extruder head. What is causing this to happen? I’ve confirmed that the build platform magnets are sitting within the respective counter bored areas of the platform arm.

One more thing: It seems that the model of printer that I received is not entirely clear to me. The label on the back of the printer says MBOT Grid II. The label on the box it came in says MBOT Cube II. The poorly written instruction manual references both. ReplicatorG software machine setting indicates MBOT Cube dual. The printer frame is black metal, not wood. Does it matter?

OK, after searching some more I think I activated the second extruder by changing the number of Tool from UNKNOWN to 2 and then confirming to have it update the motherboard. I found this in the Machine Settings section or something like that. After do that the LED display then showed the option for adding the filament to the Left Extruder, and I was successful at adding the second filament. Now I need to figure out how to use it in a build. It would have been nice if the instructions specified this setting needed to be adjusted if the printer was built as DUAL. Still have concerns about the build platform crashing into the extruders. I’ve noticed that if I home out the printer between prints the crash event doesn’t happen. But still, there should be something build it somewhere to prevent this from happening should someone forget to home the printer out each time.

To prevent crashing when moving, the end stop Switches must be controlled. I’ve had it delivered where the Switches were wrong connected. Then, when I switched to the Grid-version I had to adapt as well the z-Switch because it was not touching “soon” enough and ramming the plate.

Thanks for your reply Bycycle. I searched high and low for the Z-axis top travel limit switch. Couldn’t find it. The closes thing I could find was what I believe is limit switch attached to the extruder which is used to help level the build platform to the extruder. The LED on that switch is what is observed as the extruder moves between three locations on the build platform and you adjust the height of the build platform using the thumbscrews beneath it. Anyway, could they possibly using this limit switch as the Z-axis top travel limit switch?

One more note… In order for that switch to be triggered by the build platform the extruder x and y position must be such that the extruder nozzle tips are aligned with the cutouts in back right corner of the build platform. If that doesn’t happen the build platform could crash the extruder nozzle tips. I doesn’t seem to happen if I home the printer first before I start a build. Should it be absolutely necessary to home the printer first each time?

Yes, on the grid, the z-axis top Switch is below the Extruder Motor. I’ve removed it from there becaus IMHO it is wrong: as soon as you are printing a your Model isn’t perfect, the Switch can touch your model and Smash everything away. Or a part of it. In that case, the print is inusable.
Therefore I’ve put the Switch near the rode: and decide where is “Maximum” when the plate is levelling up.
And to my knowledge: no Need to prime the home-z-axis each time. only when you remove it. The cutouts are nice so when the head is heating up (and it is over a cut out), it won’t melt a hole into the plate.


Hi Bycyle, Thanks for the input on z-axis top switch. You have a Grid Dual or Single? If you have the Dual, have you had any luck aligning the extruders so the colors don’t over lap. I see in the Settings Menu where you can align the nozzles by entering a number for the most align X and Y print lines in a test extrusion similar to how Makerbot allow you to align there’s, but I’m not finding where or how to go about printing that test extrusions.

Hi Allen
Sorry for that very late Response:I’ve removed the 2nd head as I’ve no Need of different colour and the risk of slamming the structure down was to high (happened twice). If the plastic bends up, the 2nd Extruder can slam into the harden plastic. It is not a mbot3d issue. it is in my eye a General challenge.