Making sure everything is ready to press PRINT

Hi there,

I am finished building my mbot cube dual extruder kit and am having some problems with levelling, calibrating and software. When I select level build plate it jams in the back right hand corner and makes a very loud noise. Also I can’t seem to find “Mbot dual” in the select printer area in the top menu. Uploading the firmware seems to be a finicky task as well.

here is a video about how to calibratet the plateform for cube you can have a check

about the problem you meet ,can you send me a video about it ,I will check what lead to the problem

I don’t suggest your update the firmware ,since the new version is more suitable for your new machine .
and can you tell me what do you mean when you say "you can’t find the Mbot dual " ,where you choose this selection ?

I have the same problem. But I can not watch this video. This site is blocked in Russia. When I use another DNS then this video is still not downloaded. Can you write how to solve this problem?

After many attempts I downloaded and watched video. Set up a gap on the axis Z successfully. But I did not understand whether the X, Y, Z sensors operate in the JOG-mode? May be necessary to change the settings? And why do not always work the motors? Sometimes in some direction stops moving, and then after some time again works. Instead of rotation clicks are heard.

Problem solved: were improperly connected cables from the endstops.