Mbot 3D cube dual plywood problem with SD card

My cube dual cannot read the .x3g or .s3g files i have the message " SD cars is empty " if i make a folder can see the folder but not the files in the folder
i test the SD card with original firmware when i first got the printer last year and print from SD with no problem.
After i start using the printer with USB only know i have the latest firmware (if is the latest) SAILFISH 7.5.1 for MBot3D
any solution to the problem?

Probably the SD card contact pins are damaged, need to have it replaced.

I probably don’t have the same firmware version as you, so no guarantee this will help. But I have found that files with long and complicated file names often do not show up when printing from the SD card. So my suggestion is to limit the file names to short names, and also remove any special characters and maybe even spaces.

Thank you very mach for the suggestion i did rename the file and it worked thanks again

no i disagree because it reeds the folders (directories) and i have tried another card and the sane think happened