Mbot Cube Dual Head Setup & Other Questions

I have a couple of setup questions.

  1. with the dual head where do you position the print head for center,
    a. Between (center) of the two heads
    b. On the left head
    c. On the right head.
  2. I have found conflicting info on the proper gap between the build pate and the nozzle. So what is the correct gap setting.
    a. 1mm
    b. .5mm
    c. one piece of paper
    d. two pieces of paper
    or what?
  3. I am finding that the gap with a raft or without a raft is the same. So the raft prints fine but when I don’t use a raft the gap is too large and the filament will not stick to the build plate. This sounds like a software issue but I am not sure.
  4. Does anyone know if the firmware will recognize max limit switches as I would like to add them.
  5. Does anyone know if the new Gap/Leveling LED for the Mbot GridII can be added to the Mbot Cube. If what would the part # be of the LED and how to order.
  6. I am having x-drift and all mechanical parts are set correct. The Mbot has fix current Stepper Drivers. Has anyone replace them with the new DVR8825 adjustable digpot ones.

My Grid II dual seems to be printing well after I used a single piece of copy paper to set the gap between the nozzle and build platform using the platform leveling routine. I don’t have much knowledge on items pertaining to the rest of your questions. Still relatively new to this.

You asked about adding max limit switches. What is prompting you to want to add those? Just curious as I’ve been having issues with build platform crashing into my extruder and noticed there is no limit switch for the top z-travel control, except for the limit switch on the extruder itself which is used level the build platform to the extruder nozzle.

Good luck with your project.

On my Cube, I use the right extruder to find center. To level and gap the build plate, I used a piece of copy/printer paper, 20#, folded in half.I screw down the wing nuts under the build plate to lower it as much as possible. I jog the Z axis all the way to the top, triggering the end stop. Then I move the right extruder until it’s directly over one of the three wing nuts. I place the folded sheet of paper there, and loosen the wing nut until the paper is trapped between the bed and the right extruder. Then I back it off until the paper can slip out again. Repeat for the other two wing nuts.

davensac: I have the Cube so I am not sure about the Grid II but it sounds like you do not have the platform homed correctly. The max travel limit switch for the platform should be located on the center top inside back wall just above the z-axis drive screw. It is triggered off the plate that the z-axis stepper motor moves up & Down it should stop it from crashing in to the extruder unless the gap you have set is incorrect. I think the correct gap is 1mm but I am trying to get that confirmed.
I want add the max travel limit switches because the unit loses home and will over travel and crash into the bearing supports.
Fritz_toch: I am currently using the right extruder also but just trying to get conformation that is correct. I use the built in level function and do as you do gapping at each level screw. But at this time I am using 1mm shim for the gap. Again trying to confirm the correct gap. Hopping a Mbot rep will respond with the correct info.

Why are you “losing home”? Either you need to check belt tension or make sure the geared wheels aren’t slipping on the rods.

All of that has been check. I think I am losing stepper pulses. The Stepper Driver is a fixed current driver. Looking at the DVR8825 boards that have digpots on them for the stepper current to see if that corrects the problem.

davensac: from what I read about the Grid II the limit switch on the extruder head is for gap & level setting. So you should not need the paper just go off the LED of that switch so when it turns on it is set. And you do that at each leveling screw.

It seems the max Z axis travel is controlled by the limit switch which is located on the extruder assembly, the same switch that has a LED which is to be observed during the leveling routine. I think the problem may be in that the distance in Z-travel of the build platform between when that switch gets triggered, and when it’s making contact (crashing) with the nozzle is very minimal. Keep in mind that when things are working correctly during the homing process the dual nozzles should align with the cutouts in build platform which I believe exist for the purpose of execution of the leveling routine and allowing the nozzles to protrude into the cutouts and therefore allowing the build platform surface to trigger the limit switch which is located near the bottom of extruder assembly. However, I’ve observed that at times the extruder assembly gets lifted up slightly from the rear guide bar, and therefore leaving the limit switch at a higher than normal position. When the limit switch is in this position this allows the build platform to then crash into the nozzles of the extruder assembly rather than first triggering the limit switch and stopping travel of the build platform. And of course when this happens the situation just gets worst since the extruder assembly just gets nocked higher from it’s normal position. This is my theory anyway. If someone can theorize otherwise, I’m all ears. I’ve checked to see if there is a way to adjust the limit switch such as to allow a greater delta between when the limit switch get’s triggered and the build platform hits the nozzles, and didn’t see such an adjustment. Next time this happens I’m going to try and take a video at post it somewhere, as I know all of this may be hard to follow.

Just for your FYI I contacted tech support and the correct gap between the extruder & build plate is 1mm. Now this is for the Mbot Cube but I think is also applies to you machine. This could be why your heads are crashing into the build plate as you have it too close.
From your statement you do not have a Z-Max up limit switch above the z axis build lift pate on the inside back panel.

I’ve scanned the printer multiple times and definitely don’t see the Z-max up limit switch. Tomorrow I’ll try and find a way to post a picture of the configuration I have on the Grid II Dual.