Mbot Cube II Dual Extruder, Issues


#1

I inherited an mbot Cube II dual extruder the aluminum chassis version. Its got several issues with it at current and I am not sure how to address them.

  1. When starting a print from SD Card (have not tried via USB) the machine homes without issue after homing the Z drops down and it attempts to (home?) to X and Y max, as there is no endstops the extruder crashes for about 3 seconds and then heats up to print temp and prints without issue.

  2. I am experiencing X skip of 10 mm or more to the right on large prints. Click For Pic … But if i print a plate of 15 whistles at .75 scale it will print them all perfectly and it takes 9 or so hours… I am not sure what the issue is… but the X axis stepper is extremely hot to the touch.

Also missing the screws for the front plastic if anyone knows that size and pitch I’d greatly appreciate it.


#2
  1. Which slicing software are you using?
  2. When you press manually on X, Y and X end stop, did it stop?
  3. What is you firmware version?
    You can send me all these detail on [email protected]

#3
  1. I am using MPrint downloaded from this site.
  2. I have diagnosed the part of issue 2… the cables had failed due to no strain relief in the printer design. I have since repaired the issue but it is still having issue 1 about crashing while starting print.
  3. 7.5 according the printer when it turns on…

#4
  1. Did you choose device as MBot cube dual(17) on Mprint?
  2. Check home offeset. Utilities => Home Offset: Y=110, X=125

#5
  1. if i select MBot Cube Dual (17) it defaults to MBot Cube Dual
  2. and the offsets are set correctly

#6
  1. After selecting MBot Cube Dual (17) On-screen window you still will see MBot Cube Dual.
  2. Your MPrint V1.3.0.6
  3. Is still having a crash problem while printing? Is Z limit switch is working properly?

#7
  1. MBot Cube Dual (17) is selected, still having issue
  2. Yes I am running the most current version
  3. Its not crashing on the Z, once you select a print form the SD card and it starts it homes X Y and Then Z… then the bed drops down and for some reason X and Y goto max but crash into the side of hte machine for 2.5 seconds then stops… it heats up and then the bed moves up and the print starts like nothing happened.

#8

Change home offeset. Utilities => Home Offset: Y=110, X=110


#9

While Attempting to change the Home Offset again… I realized it wasn’t set to the 110 125 you asked for earlier so i reset it and tried and it stops short of crashing…

even after the cable repair I am still experiencing the shift on the X axis… from my original complaint.

i am holding the tool flat to the print bed and as you can see the 30x30x30 cube leans to the left.


#10

Is you x-axis alignment? Here the article http://support.mbot3d.com/hc/en-us/articles/208253293-Checking-X-assembly-alignment-checking how to check the alignment.