MBot Cube Mini Printer Crashes

Just got a Mbot mini, but experience two issues:

  1. Sometime, the printer shot down and rebooted during the printing, and leaves an incomplete part. I am not sure about the reasons. It appears file related. The printer crashes on certain file again and again.
  2. I upgrade Mprint from 1.04 to 1.05. Then, Mprint can not start, “because MSVCP110.dll is missing”.

hope someone can give me some clues to solve the problem.

You might want to roll back to 1.04 first, if that will still work.

For failed print, if it will only occur to the specific 3D model only, that 3D model might have some issues and you can try to use Netfabb cloud service to check the file (google for netfabb cloud service for the link) before trying to print again.

I tried again couple times today.
The machine turned off by itself every time a print started, no matter what file I tried to print even the file successfully printed. The printer is able to restart after crash, but can not resume the printing.

What is the possible problem?

Is any logs I can check?

Try to print direct with USB connection to test if the same issue will occur or not. If print with USB go well, then it might have something to do with SD card or SD card reader. Otherwise, it might be something wrong with your printer and need to open service ticket with Mbot.

Just tried to use USB connection to print it directly. The printer shut down immediately when it started to print.

Probably, i need to open a service ticket.


When you mentioned, started to print, you mean when the machine start to home all axis (bed move to the back and start to move up, extruder move to around the center to the right position of the bed) or it will turn off immediately when you click print file from SD card?
A video will be great