New mbot DIY wont print!


#1

I can’t seem to get my new diy plywood kit to work. Everything is assembled, the bed levels, it can connect to my PC, but despite what slicing software I use, the printer wont actually print anything. The head will heat up to 200 degrees, but it wont move. Or if it does, the z axis will stay 10mm away from the head, so nothing will print anyways. I’ve tried using the SD card and just sending the print via USB with MPrint, Repetier, Cura, and Simplify3D. There’s not any posts on the forums about the new plywood kit so I was wondering if anyone else is having any problems with it?


#2

There is an issue I was having where the machine would have the nozzle home itself, heat up, then when nozzle gets to print temp the bed would go down and it would stop. I found out that this was to do with a feature called P-Stop. When turned off it works fine.
Utilites->General Settings->P-Stop Control->OFF

Hope this helps


#3

It seems like disabling p stop would do it but I’m not sure what you’re referring to in that path you mentioned. Am I turning off the P-stop control on my printer, on my slicing software? I checked over the settings on my printer and there’s no utilities setting on it. I scoured pretty hard and couldn’t find any mention of P-stop on my printer.


#4

Oh. I am actually refering the display on the Mbox3d unit.


#5

Mine does this, it seems to be waiting for the hotend, even though it’s at temperature. I found that if I go to control, and bump the temp down by 4 degrees, it then continues on to print normally. I can then reset the temp to what I intended. I thought it was just mine.


#6

It’s not just yours, my dude!

That’s the exact problem with mine. I figured it out just by starting and cancelling prints all day last weekend.

That seems like an easier option though. I was just waiting for twenty minutes for the print to start. If it’s not just isolated to us I’d definitely like to see what Mbot has to say. This whole kit has kind of been a mess.

Have you managed to get any successful prints? I can’t find good settings i guess and nothing I’ve tried to print this week has come out. Nor does the bed seem level-able. I find that that’s more of the fault of having a triangular leveling base on a rectangular build platform but I’d like to know your experience.

Thanks for the help, man! Happy new year!


#7

Hi. yes, I actually have some very good prints from my kit, but I almost always have to use the temperature setting trick in order to start printing. I am also having trouble with the automatic bed leveling being out a tad, but I can make it work.

I’m not 100% happy with the fitmware and I’d like to be able to edit the configuration and reinstall it. There are a few things that aren’t what I would have wanted.


#8

Just to add one thing.

A triangular leveling system is actually better. It’s a bit counterintuitive, because we’re looking at it in an X/Y orientation, but it’s always 3 points that define a plane, so 3 points is the best way to have a leveling system. With a 4 point system, it’s possible to get a warped plane, which is a bad thing all around. It actually becomes more difficult to get a flat levelled system. (Example, a 3 legged stool never wobbles.) It takes a bit more patience to level the bed, since each screw affects both X and Y dimensions, though you can level the X dimension via the 2 screws in the back first, then level the Y with the one up front.

Also a caveat to the “good prints” – I can’t seem to get them to stop warping. I have a lot of printed objects with curved bases along the bottom, and it’s getting to be a problem for things that I want the printer to do. I have found that it’s mush better than the old Prusa i3 that I have, but I sorely miss having a heated print bed. I am therefore going to build a solution for that problem.


#9

Jump back to a previous firmware. The guy who sold to me used said the new firmware doesnt work properly.