How to enable heated build plate in MPrint?


#1

Hello, I have added a heated build platform to my Cube Dual Kit, but I cannot find a place in the MPrint software to turn it on for a print. The only temperature settings in Preferences are for the extruders. Thank you.


#2

Hi,
MPrint software do not have fucntion or setting regarding heated bulid platform. You need to turn on heated build platform manually.


#3

Robin,

What do you mean by turn it on manually? I dont see anywhere on the printer itself to “enable during print”.
I too am having the same issue where the heat bed pre-heats no problem, however when it comes time to print, it does not remain heated.

Cheers


#4

Same here, how do you enable it manually other than preheat?


#5

Any luck with this??


#6

Looks like we’re being ignored


#7

Those bastards… :stuck_out_tongue:
I was able to get the HBP to run during print by using ReplicatorG, and editing the GCode (When you generate the GCode in RepG, the HBP is set to M190 - It’s actually M109).
I tried Using MPrint to compile a GCode file, then imported that GCode it into RepG. However, when I then compile the .x3g file for the SD card - in RepG, and try to print, the printer crashes during the startup GCode (When going to the wait position where it pre-heats at the front left of the printer), it just keeps going and going. That happens even when I dont change anything with the GCode, seems as though RepG (Or at least my version of RepG) doesnt properly compile the GCode exported by MPrint… Phew.
I’ve also tried the “Edit profile” in MPrint, and setting HBP in the C code. No luck.Hopefully the include a HBP function in MPrint soon… I like how MPrint compiles, and the quality.


#8

At the moment only preheating or if preheating had external control
then you can turn on in external controller but there is not any internal function
to turn on heating bed in 3D printer.


#9

Hey Chris. Check out my recent post about the HBP. It’s quite convenient having the arduino controlling it separately.


#10

Hi Croach,

I think Mprint disable the HBP internally and filter out all HBP command while it generating the g-code and .x3g file. Edit the Mprint machine & filament profile or even edit my own start/end g-code with HBP setting, but the g-code generated by Mprint (OnlinePrint.gcode) is still filtered out.

But there’s still a work-around. :slight_smile:

Indeed, the .x3g generated from the post-editing Mprint g-code by RepG would crash the printing. I think Mprint actually use “GPX” as the g-code to x3g converter, which could be found under the “tools” folder of Mprint installation path, also the configuration file specific for MBot series printer (gpx.ini). Somewhere in gpx.ini define a variable “has_heated_build_platform=0” to filter the HBP command, just change this the value to 1 to let it compatible with HBP. Generate the .x3g with your post-editing g-code at command-line under this folder with command like “gpx.exe -x gpx.ini OnlinePrint.gcode”, it should generate x3g without warning and make your printing not crash due to HBP.


#11

hi
it is possible to give me more information about command line part?


#12

The “command line” I mean is the DOS like command prompt (cmd.exe) in Microsoft Windows system. Make a search in Google about “Windows command line”, lots of article will guide you how to launch this command prompt in Win7, Win8, or Win10.

In this DOS command prompt, switch to the folder which the gpx.exe is located under Mprint installed path. Execute the command “gpx.exe -c gpx.ini (Your G-Code)”, and it should generate a .x3g file for the Mbot printer. (Also make a search in Google for how to switch current folder, and execute *.exe in command prompt if you don’t know)

Best Regards.